More top problems

Oldmsct

Dedicated Member
American Zeds
Joined
Aug 5, 2020
Messages
81
Location
Delphi, Indiana
Model of Z
3.0I
Hello all, A newby from Indiana here. I just came aboard because it appears there is wealth of good info from a diverse group of like minded Z owners. Thanks to all in advance!!!

My problem is: my CD player has a stuck disc in it. In the process of trying to fix the problem I removed the NEG. battery cable. This was supposed to (re-set) the system and help release the CD. BIG MISTAKE. Should have attached a Battery Minder to the cable to maintain the computer history.

My top would no longer go down!! It unlatched, but would not move. I used the allen wrench to re-secure it so I could drive. Since then I have tried to pull the red release tab in the trunk. It may have moved, not sure, but now after re-setting the power windows I can finally manually drop the top. The red tab must have moved or the top would not go down at all. Now the top will not power up. The motor hums but nothing happens. Could the red tab be stuck out in a released mode? I can't move it in or out. I can haul the top up manually. I know, it sounds like a hydraulic problem, BUT, I can't help think (hope) there is an some more simple fix. Why would all be well until I removed the NEG. battery cable??? Also, I cannot set the clock either. Everything else works. It seems the 2 issues are related???
BTW, the CD is still stuck, but who cares??? LOL
 

t-tony

Zorg Expert (II)
Supporter
British Zeds
#ZedShed
Joined
Dec 31, 2013
Messages
39,848
Location
Torksey Lock,Lincoln, England
Model of Z
Z4 3.0 Auto
Hi and welcome from me here in the UK. I had a similar issue with the CD player in my 2003 Z4. After reading up on the internet i used some gentle persuation with a light tapping on the CD "cassette" holder and it came out. I gave the CD cassette a liberal spray with Silicone Spray, on the underside, and refitted it and, touch wood, it has been ok since. These cars can go into a delivery/transport mode when the battery is changed or disconnected, this can be reset by some diagnostic equipment.

Tony.
 

Oldmsct

Dedicated Member
American Zeds
Joined
Aug 5, 2020
Messages
81
Location
Delphi, Indiana
Model of Z
3.0I
Hi and welcome from me here in the UK. I had a similar issue with the CD player in my 2003 Z4. After reading up on the internet i used some gentle persuation with a light tapping on the CD "cassette" holder and it came out. I gave the CD cassette a liberal spray with Silicone Spray, on the underside, and refitted it and, touch wood, it has been ok since. These cars can go into a delivery/transport mode when the battery is changed or disconnected, this can be reset by some diagnostic equipment.

Tony.
Thanks Tony, Could I use a C-110 code reader to reset the system?
As far as the CD, DON'T FORCE IT, GET A BIGGER HAMMER!!!.
 

t-tony

Zorg Expert (II)
Supporter
British Zeds
#ZedShed
Joined
Dec 31, 2013
Messages
39,848
Location
Torksey Lock,Lincoln, England
Model of Z
Z4 3.0 Auto
I'm not sure that a C-110 would be able to re set the transport mode. Carly might be up to the job.

Tony.
 

Oldmsct

Dedicated Member
American Zeds
Joined
Aug 5, 2020
Messages
81
Location
Delphi, Indiana
Model of Z
3.0I
I'm not sure that a C-110 would be able to re set the transport mode. Carly might be up to the job.

Tony.
I'm taking it to our local BMW (stealer) tomorrow. Just bite the bullet, grin and bear it. LOL.
 

t-tony

Zorg Expert (II)
Supporter
British Zeds
#ZedShed
Joined
Dec 31, 2013
Messages
39,848
Location
Torksey Lock,Lincoln, England
Model of Z
Z4 3.0 Auto
Please let us know how you get on.

Tony.
 

Oldmsct

Dedicated Member
American Zeds
Joined
Aug 5, 2020
Messages
81
Location
Delphi, Indiana
Model of Z
3.0I
Well, I'm in love again!!! All fixed. Just a simple re-program. Wish i had the devise to do it myself. The local BMW stealership charged $150 (about 115 #sterling, I think) for the 15 minute job. OUCH!!!
 

t-tony

Zorg Expert (II)
Supporter
British Zeds
#ZedShed
Joined
Dec 31, 2013
Messages
39,848
Location
Torksey Lock,Lincoln, England
Model of Z
Z4 3.0 Auto
That does hurt somewhat but I'm glad you have it back in working order.
Was it the "Transport" mode issue please?

Tony.
 

Oldmsct

Dedicated Member
American Zeds
Joined
Aug 5, 2020
Messages
81
Location
Delphi, Indiana
Model of Z
3.0I
The work order receipt did not specify. It only said " cleared fault codes".
BTW, the cost was actually $130. U.S.!! Still not cheap, but better than they quoted at 1st.!!!

As always, thank you for your help. It's really nice when a complete strange lends a helping hand, although, perhaps we are no longer strangers!!
 
Top