Z4 on board computer fault

MikeH54

Dedicated Member
British Zeds
Joined
Jan 25, 2018
Messages
40
Location
Cowbridge, Vale of Glamorgan
Model of Z
Z4 2.0
Seeking some advice on what could be causing the OBC to not show any information when depressing the stalk. The display seems to be working fine as the clock, service indication all seem Fine and when I first drove it did display the range of miles but Wouldn't switch to show other features. I did change the battery but since then even the range indication no longer shows..I have had the binnacle out but nothing obvious and ideally want to avoid having to send that away if possible
 

Attachments

Layor

Zorg Addict
Supporter
British Zeds
Joined
Oct 13, 2017
Messages
341
Location
Llandrindod Wells, Powys
Model of Z
Z4 SDrive 23i M Sport 2.5Ltr. H.T Convertable
Hi Mike,
Not sure if I can help, but have you tried to do a re-set? With ignition off, hold the L/R button down (between the dials) Turn the key to position 1 wait until 'R' or 'Reset' flashes then briefly press the button again. This will normally reset the service interval but might just reset other items.
Alternatively, disconnect the battery, wait a few minutes then reconnect. Perhaps you may have already tried this with no success, so the only other way is to get someone near you with a 'Carly' or similar to do a diagnostic. Unless, of course, someone has had this problem and can help.
Colin.
 

Layor

Zorg Addict
Supporter
British Zeds
Joined
Oct 13, 2017
Messages
341
Location
Llandrindod Wells, Powys
Model of Z
Z4 SDrive 23i M Sport 2.5Ltr. H.T Convertable
One other thing, again a long shot, have you checked the fuses? 12, 23 and 24 are the instrument cluster fuses. May be worth a look.
Colin.
 

MikeH54

Dedicated Member
British Zeds
Joined
Jan 25, 2018
Messages
40
Location
Cowbridge, Vale of Glamorgan
Model of Z
Z4 2.0
One other thing, again a long shot, have you checked the fuses? 12, 23 and 24 are the instrument cluster fuses. May be worth a look.
Colin.
Hi Colin have tried neither of those tactics so will give them a go and let you know, thanks for your prompt response

Update: Have checked the fuses physically and with meter and all working, also reset1 had no effect eithe
 
Last edited:

Layor

Zorg Addict
Supporter
British Zeds
Joined
Oct 13, 2017
Messages
341
Location
Llandrindod Wells, Powys
Model of Z
Z4 SDrive 23i M Sport 2.5Ltr. H.T Convertable
Hi Mike,
It looks as though you may have to try the OBD adapter to diagnose the fault. I have one but, at the moment there is no way I am able to get down to you. Hopefully, there maybe someone closer who may be able to help. Or, someone on the Forum who has had a similar problem. Don't give up yet though!
Colin.
P.S. Not sure what year your Zed is but, has there been any water ingress in its past history. Just thinking bad contacts etc. The stalk button is obviously working for you to be able to change some things so maybe the info from OBC just not able to get through?
Just thinking out loud!
Colin.
 

MikeH54

Dedicated Member
British Zeds
Joined
Jan 25, 2018
Messages
40
Location
Cowbridge, Vale of Glamorgan
Model of Z
Z4 2.0
Might have to take it into the dealership - they have quoted a cost of £108 for the first hour just to look at it. Not keen on that option just yet though what does a Carly box cost
 
Last edited:

Layor

Zorg Addict
Supporter
British Zeds
Joined
Oct 13, 2017
Messages
341
Location
Llandrindod Wells, Powys
Model of Z
Z4 SDrive 23i M Sport 2.5Ltr. H.T Convertable
Hi Mike,
Sorry for delay in replying. As you have looked into the Carly and the software, you will have seen the prices for those items. In comparison to what the dealer is going to charge for the first hour it's a no-brainer!!
In all seriousness, I have found the Carly to be invaluable and has saved me quite a bit in time and money, as, if there is a fault, it will give the code from which you can identify the sensor where the problem is occurring.
For example, I changed all my brake pipes/hoses for the steel braided type (makes a heck of difference!) and although I bled the system, I was getting warning lights on the dash. I plugged in the adapter, fired up the ipad and it gave me the code 005E21. This turned out to be the sensor for the front brake line on the master cylinder, I did do a re-bleed of the system but all was fine, so, before paying out £25 for another sensor, I removed the sensor, cleaned it, replaced it and no warning lights. I've have been told that someone else had a similar problem and did exactly the same but the lights came back on after a week or so. If that should happen then it's okay, I will replace the sensor, but I know what the problem is and am able to solve it.
Can I just say, I have nothing to do with Carly and there are other adapters out there, but it is not just a one-off fault finder, it will be useful in times to come. There are a few sites on the internet that give the codes and their meanings and, of course, you can always ask on this Forum. I don't claim to know all there is to know about the Carly, there are many more folk out there that are far more savvy than I. But if I can offer help then it is my pleasure.
Hope this ramble will help:thumbsup:.
Colin.
 

MikeH54

Dedicated Member
British Zeds
Joined
Jan 25, 2018
Messages
40
Location
Cowbridge, Vale of Glamorgan
Model of Z
Z4 2.0
Hi Colin thanks for the insight and application on the Carly. Sounds like I should invest in one I haven't done an in depth review of the system yet so will give it a go over the weekend . Just want some confidence it will give me a ode for the problem. I guess an assurance the OBC will be covered
 

Redline

Zorg Expert (I)
British Zeds
Joined
Mar 10, 2015
Messages
6,756
Location
Nuneaton
Model of Z
E89 20i msport
Does anything happen when you press the button on the stalk?
It sounds to me as though the switch or cabling is faulty if there is no response to the button press.
Could simply be dirt in the switch or a broken contact. I would discount that first before looking for more complex problems.
 

Layor

Zorg Addict
Supporter
British Zeds
Joined
Oct 13, 2017
Messages
341
Location
Llandrindod Wells, Powys
Model of Z
Z4 SDrive 23i M Sport 2.5Ltr. H.T Convertable
I agree with Redline, it could be something as simple as a wiring fault. If you have a multimeter or know someone who has one, it would certainly be worth doing some checks first. It would make life easier if you had a wiring diagram, I'm not sure what year your Zed is but here
is an image for a 2009 Z4. It's the only one I could find and may not (and probably will not!) be any use to you. It's only part of the system.
I don't know if Redline or anyone else can provide any more info for you?
2004 bmw car-fuse-box-wiring-diagram.jpg
 

MikeH54

Dedicated Member
British Zeds
Joined
Jan 25, 2018
Messages
40
Location
Cowbridge, Vale of Glamorgan
Model of Z
Z4 2.0
U
Does anything happen when you press the button on the stalk?
It sounds to me as though the switch or cabling is faulty if there is no response to the button press.
Could simply be dirt in the switch or a broken contact. I would discount that first before looking for more complex problems.
Hi Redline no nothing happens when I pres the switch. How would I check it out. Do I need to remove the stalk and is it easy to get to
 

Redline

Zorg Expert (I)
British Zeds
Joined
Mar 10, 2015
Messages
6,756
Location
Nuneaton
Model of Z
E89 20i msport
U

Hi Redline no nothing happens when I pres the switch. How would I check it out. Do I need to remove the stalk and is it easy to get to
I think we need someone who has the wiring diagram. Going to have to follow it through. Am sure there will be a connector of some sort under the steering column cowl or the switch may come right off. Need to find the contacts for the end switch and test that first. Then, if it’s not that, then track the wiring back to wherever it goes. I wouldn’t be surprised to find somewhere where the insulation has worn away and is shorting it out.

I don’t expect there will be any codes for a switch fault in a car this old.

And body help on removing the indicator stalk?
 

philiper

Zorg Addict
British Zeds
Joined
Feb 24, 2018
Messages
351
Location
East Anglia
Model of Z
E86 Montego Blue Auto
I added cruise control to my 2004 car when I had it, and it was 1 screw under the cowl to open and then the stalk slides in, think it is the same for the other 2 stalks! I have a spare stalk at home, can look and see how it fits, but believe it is also just sliding in, so undo the top screw, remove the cover and slide the stalk out job!
 
Last edited:

Redline

Zorg Expert (I)
British Zeds
Joined
Mar 10, 2015
Messages
6,756
Location
Nuneaton
Model of Z
E89 20i msport
I agree with Redline, it could be something as simple as a wiring fault. If you have a multimeter or know someone who has one, it would certainly be worth doing some checks first. It would make life easier if you had a wiring diagram, I'm not sure what year your Zed is but here
is an image for a 2009 Z4. It's the only one I could find and may not (and probably will not!) be any use to you. It's only part of the system.
I don't know if Redline or anyone else can provide any more info for you?
View attachment 81871
Sorry Colin - missed your post. This looks like just the heating & ac wiring. Can’t get the second one to load.
Will check if I have an E85 diagram when I get chance.
Ian
 

Layor

Zorg Addict
Supporter
British Zeds
Joined
Oct 13, 2017
Messages
341
Location
Llandrindod Wells, Powys
Model of Z
Z4 SDrive 23i M Sport 2.5Ltr. H.T Convertable
This is the diagram from the link in my last post. I did try and expand it but it becomes 'blocky'. Hope it may help.
Colin.

e-85-bmw-z4-wiring-diagram-dolgular-schematic-diagram-of-bmw-z4-airbag-wiring-diagram.jpg
 

MikeH54

Dedicated Member
British Zeds
Joined
Jan 25, 2018
Messages
40
Location
Cowbridge, Vale of Glamorgan
Model of Z
Z4 2.0
Just like to thank you all for your efforts on my behalf. Am happy to have a go at getting the stalk out though the sites I've seen say remove the steering wheel and whilst I've got the tools I'd be a bit nervous about the airbag, even with the battery disconnected. If anybody's done the indicator stalk without removing the wheel it would be good to know.

I'm still not sure how to test it without a circuit diagram unless I bought a replacement, there's one on eBay for £25.00, new they're nearly £70.00, and just swapped it out. Could always sell it if it didn't change anything.
Thoughts..??
 

Redline

Zorg Expert (I)
British Zeds
Joined
Mar 10, 2015
Messages
6,756
Location
Nuneaton
Model of Z
E89 20i msport
You’re not working on the steering wheel itself so there shouldn’t be anything to much to worry about over the airbag.
You just need a simple cheap multimeter to test out the switch, but first, you’ll need to know which pins in the connector are for the end computer switch.
 
Top