Yellow oil light on dash

Dave Slayter

Regular Member
Joined
Apr 2, 2018
Messages
19
Hi
I've just bought my second Z3 (3.0 litre) to replace my soon to be sold black 2.8. Really lovely and drives amazing with 70k on. I notice the yellow oil light (at bottom of dash) comes on for 5-10 seconds when first start engine and then goes off and doesn't come on again (until next start car). The 'red' oil light at top of dash goes straight off. Neither lights show when driving.

I've checked oil level and is fine. Car just had oil change. Should I worry? Oil pressure sensor change needed? Anyone had same with theirs? Ideas and advice appreciated. Dave
 

Stevo7682

Zorg Guru (V)
Supporter
British Zeds
Scottish Zeds
Joined
Apr 1, 2016
Messages
6,625
Location
maybole
Model of Z
Z3 Individual dakar
Hopefully one of the zed 4 owners will be along soon to confirm but I have seen this same issue on a 3 series and it turned out to be a fault with the oil level sensor.
Stephen.
 

t-tony

Zorg Expert (II)
Supporter
British Zeds
#ZedShed
Joined
Dec 31, 2013
Messages
39,332
Location
Torksey Lock,Lincoln, England
Model of Z
Z4 3.0 Auto
Has this issue only appeared since the last oil change Dave, or was it the reason for the oil change maybe before you bought the car? Oil level sensor is an issue I have only ever come across once and that was on a Merc. Vito.

Tony.
 

mwpe

Zorg Guru (IV)
Supporter
Joined
Dec 8, 2011
Messages
3,533
Location
Camberley
Model of Z
3.0
It will be the sensor in the sump, I have had it happen twice on E46 325ti's with the M54 engine. Very easy to change but you need to drain the oil so best live with it until the next oil change.
 

Mint

Zorg Expert (I)
Supporter
British Zeds
East Anglian Crew
Joined
Sep 23, 2012
Messages
11,483
Location
Stafford, UK
Model of Z
2.2 & 3.0 Sport
On my 2.2 (same M54 based engine as my 3.0) when the oil level is a bit low the yellow oil light flashes when I switch off. Just telling me she needs a drink:D
 

mwpe

Zorg Guru (IV)
Supporter
Joined
Dec 8, 2011
Messages
3,533
Location
Camberley
Model of Z
3.0
On my 2.2 (same M54 based engine as my 3.0) when the oil level is a bit low the yellow oil light flashes when I switch off. Just telling me she needs a drink:D
It is meant to do that but when it comes on after start up and then goes out it is usually the sensor. Both times when I have had it, sensor replacement has fixed it.
 

Dave Slayter

Regular Member
Joined
Apr 2, 2018
Messages
19
Has this issue only appeared since the last oil change Dave, or was it the reason for the oil change maybe before you bought the car? Oil level sensor is an issue I have only ever come across once and that was on a Merc. Vito.

Tony.
Not sure. I didn't notice on test drive. But as light goes off initially and pops back on for 5 or so secs I could habe missed it. I asked for oil change as condition of sale. Dave
 

Dave Slayter

Regular Member
Joined
Apr 2, 2018
Messages
19
It is meant to do that but when it comes on after start up and then goes out it is usually the sensor. Both times when I have had it, sensor replacement has fixed it.
Hi. That is good to know. So I can possibly stop stressing so much about my new wheels? Dave
 

colb

Zorg Guru (IV)
British Zeds
Joined
Nov 25, 2012
Messages
1,226
Location
Newport, South Wales,UK
Model of Z
Z3 M43 1.8 (1999) and Z4 E85 2.5 (2003)
Just changed mine on my E85 Z4, had fault code flag up showing Thermal Oil level Sensor, new one fitted when I changed the oil and cleared code with BMW Scanner 1.4. Ran scan yesterday and code clear at the moment. I think its settled down but will be monitoring how it behaves and keep an eye on the level using the dipstick.
 
Top