Welcome to ZRoadster.org - BMW Z1 Z4 Z8 Z3 Forum and Technical Database

If you want to join in with the discussion, and see the areas which are available only to members then sign up now!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Whistle whist accelerating...

Discussion in 'Z3 Roadster & Coupé' started by pina4greg, Nov 18, 2014.

  1. pina4greg

    pina4greg Dedicated Member
    Australian Zeds

    Joined:
    Sep 23, 2014
    Messages:
    52
    Likes Received:
    57
    Trophy Points:
    31
    Location:
    Perth, Western Australia
    Model of Z:
    2000 z3 2.0 litre, 5 speed manual
    I hear a high whistle whilst accelerating. it stopped upon cruising....could it be a vacuum pipe leak or something...??
     
  2. David Cullen

    David Cullen Zorg Legend
    Supporter The M44 Massive

    Joined:
    Jul 8, 2014
    Messages:
    760
    Likes Received:
    366
    Trophy Points:
    76
    Location:
    Prosperous, County Kildare
    is your acceleration or idle affected at all? is the noise coming from the engine bay?
     
  3. Lee

    Lee Zorg Guru (V)
    British Zeds #ZedShed M Power

    Joined:
    Mar 26, 2014
    Messages:
    2,982
    Likes Received:
    3,786
    Trophy Points:
    187
    Location:
    Basingstoke
    Model of Z:
    Z4 Coupe
    I used to get a whissle around 70mph between the roof and windscreen seal. never did fix it, it fixed itself :D
     
    • Like Like x 1
  4. pina4greg

    pina4greg Dedicated Member
    Australian Zeds

    Joined:
    Sep 23, 2014
    Messages:
    52
    Likes Received:
    57
    Trophy Points:
    31
    Location:
    Perth, Western Australia
    Model of Z:
    2000 z3 2.0 litre, 5 speed manual
    think its engine bay....and only whilst starting off etc...no much speed at all..
     
  5. David Cullen

    David Cullen Zorg Legend
    Supporter The M44 Massive

    Joined:
    Jul 8, 2014
    Messages:
    760
    Likes Received:
    366
    Trophy Points:
    76
    Location:
    Prosperous, County Kildare
    i had it before in a different car and was plastics around the window, sounded like it was coming from the air vents, took months to find out what the issue was until one day when we were doing around 70kph the passenger let down the window and the noise went lol simple ;-)
     
    • Like Like x 1
  6. t-tony

    t-tony Zorg Expert (I)
    Supporter British Zeds #ZedShed

    Joined:
    Dec 31, 2013
    Messages:
    31,717
    Likes Received:
    14,964
    Trophy Points:
    220
    Location:
    Torksey Lock,Lincoln, England
    Model of Z:
    Z4 3.0 Auto
    If you can reproduce the noise whilst stationary Greg it's more likely a vacc leak on the engine some where. If it only happens when moving look to door and roof seals as suggested.:)

    Tony.
     
    • Like Like x 1
  7. pina4greg

    pina4greg Dedicated Member
    Australian Zeds

    Joined:
    Sep 23, 2014
    Messages:
    52
    Likes Received:
    57
    Trophy Points:
    31
    Location:
    Perth, Western Australia
    Model of Z:
    2000 z3 2.0 litre, 5 speed manual
    THANKS AGAIN GUYS...WILL CHECK IT WITH THE BONNET UP AND SEE IF IT HAPPENS WHILST STATIONARY. WILL ADVISE.
     
    • Like Like x 1