Scanned error codes - 1999 Z3 2.8

Mike Klein

Regular Member
Joined
Mar 22, 2017
Messages
11
Hi al!
My Z is due for inspection and the dreaded check engine light is on. Ran the scanner and it comes up with 5 codes.
First two are codes 25 and 55, Lambda Sensor Heater -Bank 1 - O2 sensor and Lambda Sensor Heater -Bank 2 – O2 Sensor.
I recently replaced both pre-cat O2 sensors and while it cleared the original fault, it now comes up with these two.
Also, when I looked at the sensor cables, the feed cable going to bank 2 sensor was not fed correctly and laid up against the engine and melted some of the wire insulation, down to bare wire....#1 was fine. Replaced both sensors...probably needed it with 177K miles and I have no idea if they were ever replaced.
Not I get these sensor heater errors. Ideas?

The other 3 look like they may be related, they come up in order, 50, 35 and 126:
50: EVAP Control Valve or Response Monitoring Level 2
35: Aux. Air Injection System Relay
126: Activation Tank Leak Pump Solenoid

Any thoughts on these error codes? is one causing the others or?

Reset codes after O2 sensors replaced pre-cat.
Also, repaired the cable running to bank #2 sensor.
The code errors came in after the above was done. Drove it several times and re-read codes. Cleared and read again, The error codes I listed above were read after all of this.
 

Attachments

Last edited:

andyglym

Shiny Dust Caps Make Your Zed Go Faster.
Supporter
British Zeds
Joined
Feb 20, 2015
Messages
20,002
Location
Moresby, West Cumbria, England
Model of Z
2.8 Roadster
:welcome: to the Forum from West Cumbria, England. Sorry, can't help with the issues, some techies will be along shortly. Cracking pics of your Zed (Zee) :thumbsup:
 

Bazza

Zorg Guru (IV)
Supporter
British Zeds
The West Country
Joined
Oct 15, 2013
Messages
2,055
Location
Verwood Dorset
Model of Z
2.8 Roadster
:welcome:from me:drinks:
 

Antm72

Zorg Expert (II)
Supporter
British Zeds
Joined
May 4, 2015
Messages
6,793
Location
South Yorkshire
Model of Z
2.8
Hello and welcome from me in South Yorkshire.
Not 100% on the errors but are obviously looking at the individual codes to do with the fuel / emmision side of things.
Have read on other faults that sometimes the check light is activated because the fuel cap is not sealing the tank properly causing vapour leaks,
The charcoal canister is designed to remove these if it is sensing a leak it may be the cause ....
Just my view im sure others will have theirs good luck with finding the issues :thumbsup:
 

Mike Klein

Regular Member
Joined
Mar 22, 2017
Messages
11
Hello and welcome from me in South Yorkshire.
Not 100% on the errors but are obviously looking at the individual codes to do with the fuel / emmision side of things.
Have read on other faults that sometimes the check light is activated because the fuel cap is not sealing the tank properly causing vapour leaks,
The charcoal canister is designed to remove these if it is sensing a leak it may be the cause ....
Just my view im sure others will have theirs good luck with finding the issues :thumbsup:
Thank you!
Good point on the gas cap Antm72. I do know this can cause issues as well but for some reason, I didn't make the connection. I will check that for sue. More to come.......
 

Nodzed

Zorg Expert (I)
Supporter
British Zeds
M Power
#ZedShed
Joined
Feb 18, 2016
Messages
8,008
Location
Forest of Dean, Gloucestershire, England
Model of Z
Z3M and Z4 (e89)
Hi and welcome.. sorry that's above my technical abilities, no hammer involved:thumbsup:
 

EnthuZiaZT

Zorg Guru (V)
British Zeds
East Anglian Crew
Joined
Dec 6, 2011
Messages
4,694
Location
Heacham Norfolk
Model of Z
Z4 28i Msport
Welcome Mike, hate to be pessimistic but you might have a cracked header, (exhaust manifold) is yours a six pot?

Mike
 

Mint

Zorg Expert (I)
Supporter
British Zeds
East Anglian Crew
Joined
Sep 23, 2012
Messages
11,629
Location
Stafford, UK
Model of Z
2.2 & 3.0 Sport
Hi @Mike Klein, :welcome: to the forum from me too in Staffordshire, UK. Good luck getting your Zee sorted :thumbsup:
 

Shelly

Zorg Expert (I)
Supporter
British Zeds
East Anglian Crew
Joined
Jul 9, 2013
Messages
22,262
Location
Norfolk
Model of Z
Z4 2.0 20i M Sport sDrive
:welcome: Hi and welcome from me too :coolsteer)
 

Mike Klein

Regular Member
Joined
Mar 22, 2017
Messages
11
Welcome Mike, hate to be pessimistic but you might have a cracked header, (exhaust manifold) is yours a six pot?

Mike
Hey Mike!
Thanks for the input.
Yes, mine's a 2.8, 6cyl. That's a thought but I hope not! LOL! I haven't been out to look at her again since my post. I do have some other things to check on, vacuum leak, etc.
 
Top