Welcome to ZRoadster.org - BMW Z1 Z4 Z8 Z3 Forum and Technical Database

If you want to join in with the discussion, and see the areas which are available only to members then sign up now!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[RESOLVED] Image uploading problem under investigation

Discussion in 'Site Announcements and Feedback' started by GazHyde, Apr 14, 2014.

  1. GazHyde

    GazHyde The Gaz Monkey
    Staff Member Administrator Global Moderator British Zeds

    Joined:
    Dec 2, 2011
    Messages:
    15,162
    Likes Received:
    9,255
    Trophy Points:
    226
    Location:
    Newbury, Berkshire
    Model of Z:
    BMW Z4 3.0Si Sport
    How large are the original files? Files up to about 5MB each are usually processed OK, but I'll double check the settings just in case...
     
  2. Bazza

    Bazza Zorg Guru (IV)
    Supporter British Zeds The West Country

    Joined:
    Oct 15, 2013
    Messages:
    1,930
    Likes Received:
    1,135
    Trophy Points:
    150
    Location:
    Verwood Dorset
    Model of Z:
    2.8 Roadster
    Gaz have re-sized on my camera to1936x1296 = 2.5MP but still no joy? have had no trouble in the past? not sure what's going on:(
    Bazza
     
  3. Bazza

    Bazza Zorg Guru (IV)
    Supporter British Zeds The West Country

    Joined:
    Oct 15, 2013
    Messages:
    1,930
    Likes Received:
    1,135
    Trophy Points:
    150
    Location:
    Verwood Dorset
    Model of Z:
    2.8 Roadster
    Gaz just managed to change my avatar picture and then change it back maybe the files of the weekend pic's are to large?
     
  4. GazHyde

    GazHyde The Gaz Monkey
    Staff Member Administrator Global Moderator British Zeds

    Joined:
    Dec 2, 2011
    Messages:
    15,162
    Likes Received:
    9,255
    Trophy Points:
    226
    Location:
    Newbury, Berkshire
    Model of Z:
    BMW Z4 3.0Si Sport
    Leave it with me Bazza, I've noticed an issue with the system which processes the images. Need to have a tinker with the server and change some settings.
     
  5. hard top

    hard top Zorg Expert (I)
    Dutch Zeds The M44 Massive

    Joined:
    Dec 5, 2011
    Messages:
    20,779
    Likes Received:
    6,060
    Trophy Points:
    213
    Location:
    Netherlands
    [​IMG]
    14 April 2014Last updated at 16:38 GMT

    Gaz trying to work it out with Tec Suport.......
     
    • Funny Funny x 5
  6. Mint

    Mint Zorg Expert (I)
    Supporter British Zeds East Anglian Crew

    Joined:
    Sep 23, 2012
    Messages:
    9,081
    Likes Received:
    6,122
    Trophy Points:
    212
    Location:
    Staffordshire, UK
    Model of Z:
    1st Z3 | 2.2 | Sport | Individual 2nd - Z3 | 3.0 | Sport
    I think the problem might be that the system will accept a maximum image size of 1800 x 1350 pixels.
     
  7. GazHyde

    GazHyde The Gaz Monkey
    Staff Member Administrator Global Moderator British Zeds

    Joined:
    Dec 2, 2011
    Messages:
    15,162
    Likes Received:
    9,255
    Trophy Points:
    226
    Location:
    Newbury, Berkshire
    Model of Z:
    BMW Z4 3.0Si Sport
    I'm not sure where you got that size from, but I'm able to upload bigger than that at the moment ;)

    It's not linked to image size, or file size as far as I can tell. I have identified what the problem is, just need to fix it. :watching:
     
  8. Mint

    Mint Zorg Expert (I)
    Supporter British Zeds East Anglian Crew

    Joined:
    Sep 23, 2012
    Messages:
    9,081
    Likes Received:
    6,122
    Trophy Points:
    212
    Location:
    Staffordshire, UK
    Model of Z:
    1st Z3 | 2.2 | Sport | Individual 2nd - Z3 | 3.0 | Sport
    Hi Gary, I got the file size from the add media screen. When I tried to upload my images into the media gallery I got this screen:
    File Size.JPG

    Must be a red herring:D
     
  9. GazHyde

    GazHyde The Gaz Monkey
    Staff Member Administrator Global Moderator British Zeds

    Joined:
    Dec 2, 2011
    Messages:
    15,162
    Likes Received:
    9,255
    Trophy Points:
    226
    Location:
    Newbury, Berkshire
    Model of Z:
    BMW Z4 3.0Si Sport
    Technically yes it is... :writing:

    You can upload images in any size to both the forum and the media gallery and it will automatically resize them to the maximum specified in the config settings. Images uploaded to the forum are resized to a maximum of 1024x768 (a size which fits the threads optimally). The media gallery has a larger setting of 1800 x 1350 as per your screenshot (mainly so you can see the images in better detail).

    If you are uploading in any size larger than these, it will do the work for you to resize them. On top of this there is an upper file size limit - which it works out before resizing - so if the resulting image will be larger than this limit it will reject it.

    It's this processing of the images which is at fault at the moment. It's not consistent in the way it fails, as I can upload a range of image sizes and it fails on some of the smaller ones as well as the larger ones.

    Hopefully that makes better sense.

    I've also moved the image upload posts to it's own thread ;)
     
  10. zedonist

    zedonist Guest

    Have you checked you are connected to the internet, this can sometimes prevent uploading ;)
     
    • Funny Funny x 1
  11. Mint

    Mint Zorg Expert (I)
    Supporter British Zeds East Anglian Crew

    Joined:
    Sep 23, 2012
    Messages:
    9,081
    Likes Received:
    6,122
    Trophy Points:
    212
    Location:
    Staffordshire, UK
    Model of Z:
    1st Z3 | 2.2 | Sport | Individual 2nd - Z3 | 3.0 | Sport
    This is the screen I got:
    Error.JPG
    So its failing to resize the images:(. When I resized them manually first they uploaded ok.

    I'll leave it with you:confused:
     
    • Like Like x 1
  12. zedonist

    zedonist Guest

    Have you checked the weight?
     
    • Funny Funny x 1
  13. GazHyde

    GazHyde The Gaz Monkey
    Staff Member Administrator Global Moderator British Zeds

    Joined:
    Dec 2, 2011
    Messages:
    15,162
    Likes Received:
    9,255
    Trophy Points:
    226
    Location:
    Newbury, Berkshire
    Model of Z:
    BMW Z4 3.0Si Sport
    Yes, that's the one. Resized images should upload fine, and will be back to normal once I've got it working again.
    I've tried weighting but it still takes ages...
     
    • Like Like x 3
    • Funny Funny x 2
  14. Mint

    Mint Zorg Expert (I)
    Supporter British Zeds East Anglian Crew

    Joined:
    Sep 23, 2012
    Messages:
    9,081
    Likes Received:
    6,122
    Trophy Points:
    212
    Location:
    Staffordshire, UK
    Model of Z:
    1st Z3 | 2.2 | Sport | Individual 2nd - Z3 | 3.0 | Sport
    Any luck yet Gary, I'm trying to upload to POTM but I am now getting
    Error.JPG
    for any image I try to uplaod:(
    (but this has uploaded ok...)
     
    • Funny Funny x 1
  15. GazHyde

    GazHyde The Gaz Monkey
    Staff Member Administrator Global Moderator British Zeds

    Joined:
    Dec 2, 2011
    Messages:
    15,162
    Likes Received:
    9,255
    Trophy Points:
    226
    Location:
    Newbury, Berkshire
    Model of Z:
    BMW Z4 3.0Si Sport
    That's actually very helpful Dave as I just had an error logged which I can tie to the issue. Getting close to figuring what is happening now :bookworm:
     
  16. GazHyde

    GazHyde The Gaz Monkey
    Staff Member Administrator Global Moderator British Zeds

    Joined:
    Dec 2, 2011
    Messages:
    15,162
    Likes Received:
    9,255
    Trophy Points:
    226
    Location:
    Newbury, Berkshire
    Model of Z:
    BMW Z4 3.0Si Sport
    @Mint, can you try and upload to the media library again. I've disabled the function which is causing the error (the logo watermark), so it should upload now.

    It's the same root cause as image uploading to the forum, which I'll try and fix tomorrow ;)
     
  17. Mint

    Mint Zorg Expert (I)
    Supporter British Zeds East Anglian Crew

    Joined:
    Sep 23, 2012
    Messages:
    9,081
    Likes Received:
    6,122
    Trophy Points:
    212
    Location:
    Staffordshire, UK
    Model of Z:
    1st Z3 | 2.2 | Sport | Individual 2nd - Z3 | 3.0 | Sport
    Ok Gary, I've tried again. Couldn't upload at 1st attempt (3840 x 2160, 2.49 Mb) but Ok at 2nd attempt (1920 x 1080. 288 Kb)
    Not the best quality but at least its uploaded:)
     
  18. GazHyde

    GazHyde The Gaz Monkey
    Staff Member Administrator Global Moderator British Zeds

    Joined:
    Dec 2, 2011
    Messages:
    15,162
    Likes Received:
    9,255
    Trophy Points:
    226
    Location:
    Newbury, Berkshire
    Model of Z:
    BMW Z4 3.0Si Sport
    I've been messing with uploading different sizes and anything around or over 2MB seems to be an issue. Image dimensions doesn't seem to have an effect.
     
  19. Mint

    Mint Zorg Expert (I)
    Supporter British Zeds East Anglian Crew

    Joined:
    Sep 23, 2012
    Messages:
    9,081
    Likes Received:
    6,122
    Trophy Points:
    212
    Location:
    Staffordshire, UK
    Model of Z:
    1st Z3 | 2.2 | Sport | Individual 2nd - Z3 | 3.0 | Sport
    Just tried again with an image size of 1920 x 1080, 839 Kb which worked ok:)
     
    • Like Like x 1
  20. EnthuZiaZT

    EnthuZiaZT Zorg Guru (V)
    British Zeds East Anglian Crew

    Joined:
    Dec 6, 2011
    Messages:
    4,587
    Likes Received:
    2,197
    Trophy Points:
    193
    Location:
    Heacham Norfolk
    Model of Z:
    Z4 28i Msport
    We still find it easier to use Photobucket (sharing site) as we can pop them on facebook as well at any time if we want to, Gazza

    Could Bazza not try that meanwhile, at least he could upload some pics, while they are still relevant,

    Mike & Sandy
     

Share This Page