Outside Air Temp Sensor

Mr-P

Zorg Addict
Joined
Feb 10, 2013
Messages
400
Location
Oxfordshire
Model of Z
Sold Z3M
Ok question for Z3M owners.

Looks like my outside temp sensor has failed gauge goes to max. BMW want well over £100 for one and system says it only fits Z3M S50 & S54 models.

My question is has anyone else had this issue and if so have you used a different sensor from one of the other Z3's which are about £20 at the most??????

Thanks in advance.
 

g8jka

Zorg Guru (V)
Supporter
British Zeds
Joined
Dec 5, 2011
Messages
2,691
Location
Telford, Shropshire
Model of Z
Z3 - 2000 2.8 Roadster
Is it the sensor or the gauge itself that has failed?

I retro fitted the M console and used a standard brass temperature sensor. It reads about 2 degrees high but I'm sure this is fairly common from other posts I have read?

Plenty available on eBay or from a company called etb instruments from what I remember.
 

Graham Saint

Regular Member
Joined
Mar 16, 2017
Messages
6
Is it the sensor or the gauge itself that has failed?

I retro fitted the M console and used a standard brass temperature sensor. It reads about 2 degrees high but I'm sure this is fairly common from other posts I have read?

Plenty available on eBay or from a company called etb instruments from what I remember.
Is the sensor that has failed, so it looks like standard sensor will work.
can anyone tell me where the external air temp sensor is located in the Z3M, I’ve looked behind headlights as there’s where it is on my z3 but nothing there in the M, any assistance would be appreciated
 

petecossie

Zorg Guru (III)
British Zeds
M Power
Joined
Dec 7, 2011
Messages
974
Location
Teesside
Model of Z
Z3 M Coupe
It’s located in front of the O/S rear wheel behind the wheel arch liner. When I did refurb of front & rear wings plus replacing sill covers on my Coupe I found the sensor tie wrapped to the remains of the mounting bracket. The sensor was heavily corroded (but was still working), I wire brushed it and put a bit of Hammerite on it before refitting to a new bracket. Work fine these days.
I’ll have a look see if I have a picture of it.
:thumbsup:
 

petecossie

Zorg Guru (III)
British Zeds
M Power
Joined
Dec 7, 2011
Messages
974
Location
Teesside
Model of Z
Z3 M Coupe
Pic of sensor in situ

DSCN5226v1.JPG



Pic of corroded mounting bracket!!!

DSCN5258.JPG
 

Graham Saint

Regular Member
Joined
Mar 16, 2017
Messages
6
It’s located in front of the O/S rear wheel behind the wheel arch liner. When I did refurb of front & rear wings plus replacing sill covers on my Coupe I found the sensor tie wrapped to the remains of the mounting bracket. The sensor was heavily corroded (but was still working), I wire brushed it and put a bit of Hammerite on it before refitting to a new bracket. Work fine these days.
I’ll have a look see if I have a picture of it.
:thumbsup:
Thank you,I wouldn’t have looked there so most useful, as I have a rust spot on that wing I will do it when I replace the panel, there’s some conflict information on these threads but I think the Z3M has a different sensor than the plastic on on the other Zoe’s so will have to find a part number,
 
Top