Welcome to ZRoadster.org - BMW Z1 Z4 Z8 Z3 Forum and Technical Database

If you want to join in with the discussion, and see the areas which are available only to members then sign up now!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need HELP quick

Discussion in 'General Banter' started by stevie_a, Mar 2, 2013.

  1. stevie_a

    stevie_a Zorg Guru (IV)
    Scottish Zeds

    Joined:
    Jan 8, 2012
    Messages:
    1,623
    Likes Received:
    1,095
    Trophy Points:
    171
    Location:
    Glasgow'ish
    Model of Z:
    Z3
    My wife has just went into the car and there are no working dials

    no fuel gauge, rev counter, temp gauge, not sure about speedometer

    what could cause this please.
     
  2. z3cade

    z3cade Zorg Guru (III)
    East Anglian Crew

    Joined:
    Dec 4, 2011
    Messages:
    1,980
    Likes Received:
    315
    Trophy Points:
    137
    Location:
    Peterborough
    First check your fuses ;)
     
  3. Aceman

    Aceman Moderator
    British Zeds 3rd Party Trader

    Joined:
    Dec 5, 2011
    Messages:
    2,204
    Likes Received:
    707
    Trophy Points:
    156
    Location:
    Wakefield
    Model of Z:
    ///M Roadster
    Yep check fuses first then try disconnecting the battery and reconnecting see if that resets it.

    Failing that there is a common fault where the wiring behind the dash binnacle can rub on one of the metal bars causing it to short, maybe worth giving that a check. I suspect it will all come back to life unexpected though and you will wonder what that was all about.
     
  4. stevie_a

    stevie_a Zorg Guru (IV)
    Scottish Zeds

    Joined:
    Jan 8, 2012
    Messages:
    1,623
    Likes Received:
    1,095
    Trophy Points:
    171
    Location:
    Glasgow'ish
    Model of Z:
    Z3
    Any hint which fuse it could be ?

    will check them when wife gets back from hairdressers

    funny this as i just baught led fuses the other week
     
  5. jonco

    jonco Zorg Guru (III)
    Supporter British Zeds The M44 Massive

    Joined:
    Dec 6, 2011
    Messages:
    1,324
    Likes Received:
    664
    Trophy Points:
    149
    Location:
    Chester
    Model of Z:
    '98 1.9 Auto
  6. stevie_a

    stevie_a Zorg Guru (IV)
    Scottish Zeds

    Joined:
    Jan 8, 2012
    Messages:
    1,623
    Likes Received:
    1,095
    Trophy Points:
    171
    Location:
    Glasgow'ish
    Model of Z:
    Z3

    Just had phone call from my wife, she has now came out of hairdressers got into car and all is ok again.... :D
     
  7. Aceman

    Aceman Moderator
    British Zeds 3rd Party Trader

    Joined:
    Dec 5, 2011
    Messages:
    2,204
    Likes Received:
    707
    Trophy Points:
    156
    Location:
    Wakefield
    Model of Z:
    ///M Roadster
    Usually the case having read people's accounts over the years. It is probably the wiring rubbing behind the binnacle that is the problem so when you get chance I would pop the clocks out and have a look.
     
  8. badman gee

    badman gee Guest

    Yep,

    You will see it again soon.

    :(
     

Share This Page