Welcome to ZRoadster.org - BMW Z1 Z4 Z8 Z3 Forum and Technical Database

If you want to join in with the discussion, and see the areas which are available only to members then sign up now!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Left Hand Indicator Problem

Discussion in 'Z4 Roadster & Coupé' started by Macca, Mar 19, 2014.

  1. Macca

    Macca Zorg Guru (II)
    Supporter British Zeds East Anglian Crew

    Joined:
    Dec 5, 2011
    Messages:
    1,064
    Likes Received:
    328
    Trophy Points:
    114
    Location:
    Wisbech St. Mary
    Model of Z:
    2.5l Msport
    This is a strange one! I can go miles using my indicator as usual then all of a sudden I get a bulb warning light come on and the usual fast "ticking" of the audible alert. The next time I use them it's fine? I have narrowed it down to the passenger rear indicator and checked all connections and they seem fine!! Any other thoughts on this before I look to change the whole cluster?
     
  2. badman gee

    badman gee Guest

    Have you fixed it Richard?
     
  3. Macca

    Macca Zorg Guru (II)
    Supporter British Zeds East Anglian Crew

    Joined:
    Dec 5, 2011
    Messages:
    1,064
    Likes Received:
    328
    Trophy Points:
    114
    Location:
    Wisbech St. Mary
    Model of Z:
    2.5l Msport
    To be honest Mark, I have no idea. I had another look today and I couldn't get it to malfunction once!! I couldnt find anything wrong, so time will tell.
     
  4. Brian H

    Brian H Zorg Guru (V)
    British Zeds Scottish Zeds

    Joined:
    Dec 5, 2011
    Messages:
    3,441
    Likes Received:
    2,495
    Trophy Points:
    195
    Location:
    Killin
    Model of Z:
    E36/7 3.0i - E85 Z4///M
    I have had a similar fault on my merc vito, sometimes I got a faulty bulb symbol and sometimes I did not. I changed the bulb to a new one and it never did it again!
     
  5. z3cade

    z3cade Zorg Guru (III)
    East Anglian Crew

    Joined:
    Dec 4, 2011
    Messages:
    1,980
    Likes Received:
    315
    Trophy Points:
    137
    Location:
    Peterborough
    Just replace the bulb Richard ;)
     
  6. Macca

    Macca Zorg Guru (II)
    Supporter British Zeds East Anglian Crew

    Joined:
    Dec 5, 2011
    Messages:
    1,064
    Likes Received:
    328
    Trophy Points:
    114
    Location:
    Wisbech St. Mary
    Model of Z:
    2.5l Msport
    I wish I could Liam but they are LEDs built into the cluster!
     
  7. t-tony

    t-tony Zorg Expert (I)
    Supporter British Zeds

    Joined:
    Dec 31, 2013
    Messages:
    30,198
    Likes Received:
    14,245
    Trophy Points:
    220
    Location:
    Torksey Lock,Lincoln, England
    Model of Z:
    Z4 3.0 Auto
    I don't know if this will help or confuse Richard,I have led bulbs in the reg plate lights on my Touareg (canbus type)and every now and then the bulb fault warning comes on and mates at work say your number plate light was out last night. I check them when I get home and all are working ok and next switch on no warning. I think it's possibly the Led's.
     
  8. z3cade

    z3cade Zorg Guru (III)
    East Anglian Crew

    Joined:
    Dec 4, 2011
    Messages:
    1,980
    Likes Received:
    315
    Trophy Points:
    137
    Location:
    Peterborough
    Ah I see Richard. Well then I think its time to chop it in for a new z4 :D
     
  9. Mint

    Mint Zorg Expert (I)
    Supporter British Zeds East Anglian Crew

    Joined:
    Sep 23, 2012
    Messages:
    8,665
    Likes Received:
    5,873
    Trophy Points:
    212
    Location:
    Staffordshire, UK
    Model of Z:
    1st Z3 | 2.2 | Sport | Individual 2nd - Z3 | 3.0 | Sport
    Or even a Z3;)
     
  10. badman gee

    badman gee Guest

    What down grade the best z3 for a z4. You must be joking!
     

Share This Page