Welcome to ZRoadster.org - BMW Z1 Z4 Z8 Z3 Forum and Technical Database

If you want to join in with the discussion, and see the areas which are available only to members then sign up now!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help needed please....

Discussion in 'Z3 & Z3 M Roadster & Coupé Knowledgebase' started by EvergreenZ3M, Sep 20, 2014.

  1. EvergreenZ3M

    EvergreenZ3M Newbie

    Joined:
    Sep 20, 2014
    Messages:
    9
    Likes Received:
    11
    Trophy Points:
    3
    Hello

    Can anyone help please.

    I have connected a code reader (C110) to my Z3M and I have the following fault codes. B8 controller hardware monitoring, B1 fault valve load circuit fuse

    Any help would be very appreciated, thank you

    Shirley :)
     
    • Like Like x 1
  2. GazHyde

    GazHyde The Gaz Monkey
    Staff Member Administrator Global Moderator British Zeds

    Joined:
    Dec 2, 2011
    Messages:
    15,103
    Likes Received:
    9,156
    Trophy Points:
    226
    Location:
    Newbury, Berkshire
    Model of Z:
    BMW Z4 3.0Si Sport
    Hi Shirley,

    I'm not familiar with those codes, does you car have any particular symptoms. Do the codes come back if you clear them and restart the engine? Just wondering if they are old codes from a resolved issue.

    Gary
     
    • Like Like x 1
  3. zedonist

    zedonist Guest

    It is an ABS fault code, it suggests that their is an issue in the circuit, which could be the wiring, a sensor, fuse, relay or ECU Controller. You need to methodically test the system to identify which of the above is at fault. Obviously a fuse is the cheapest and an ECU the dearest, so would check / test in that order.
     
    • Agree Agree x 1
  4. EvergreenZ3M

    EvergreenZ3M Newbie

    Joined:
    Sep 20, 2014
    Messages:
    9
    Likes Received:
    11
    Trophy Points:
    3
    Hello Gary and zedonist

    Thank you both for your replies

    zedonist, I did have another fault code which said I had a faulty ABS sensor, this has now been replaced with a new sensor and that fault code has now gone. I still have the other two fault codes though even after clearing/reset, so am I right in thinking these codes are actually related to the ABS sensor, and my problem is now fixed?

    Many thanks

    Shirley :)
     
    • Like Like x 1
  5. David Cullen

    David Cullen Zorg Legend
    Supporter The M44 Massive

    Joined:
    Jul 8, 2014
    Messages:
    760
    Likes Received:
    366
    Trophy Points:
    76
    Location:
    Prosperous, County Kildare
    was the sensor an after market or oem (bmw) sensor? I have read that unless it is a bmw sensor it wont reset the fault... don't know for sure, just going off what I have read
     
    • Like Like x 1
  6. EvergreenZ3M

    EvergreenZ3M Newbie

    Joined:
    Sep 20, 2014
    Messages:
    9
    Likes Received:
    11
    Trophy Points:
    3
    Hello David. Thank you for your reply. The first sensor I bought was an aftermarket one, which didn't clear the fault, so I bought another new BMW sensor, which cleared the fault straight-away, but still left the two other fault codes

    Shirley :)
     
    • Like Like x 1
  7. David Cullen

    David Cullen Zorg Legend
    Supporter The M44 Massive

    Joined:
    Jul 8, 2014
    Messages:
    760
    Likes Received:
    366
    Trophy Points:
    76
    Location:
    Prosperous, County Kildare
    I am afraid Shirley that I am only new to BMWs myself and cant be of more assistance, im sure one of the guys will pick this up and come up with a solution
     
    • Like Like x 1
  8. zedonist

    zedonist Guest

    Shirley,

    Are your dash lights on for ABS fault?

    Have you changed anything else recently on the front end of the car?

    Since changing the sensor have you been for a drive, as mentioned above the system should reset itself, usually after about 30 seconds of driving the dash fault light will go out.
     
    • Like Like x 1
  9. EvergreenZ3M

    EvergreenZ3M Newbie

    Joined:
    Sep 20, 2014
    Messages:
    9
    Likes Received:
    11
    Trophy Points:
    3
    Hello

    Thank you once again for your replies

    Yes, the ABS light on the dash is now off

    The car has been driven since and nothing else has been replaced to the front end of the car

    Shirley :)
     
    • Like Like x 1
  10. zedonist

    zedonist Guest

    I would say you don't have a problem now.
     
    • Like Like x 1
    • Thank You! Thank You! x 1
  11. EvergreenZ3M

    EvergreenZ3M Newbie

    Joined:
    Sep 20, 2014
    Messages:
    9
    Likes Received:
    11
    Trophy Points:
    3
    Hello zedonist

    I was hoping you would say that, fantastic news. Thank you so much for your help, I appreciate it

    And thank you to everyone else who replied

    Shirley :)
     
    • Like Like x 2
  12. David Cullen

    David Cullen Zorg Legend
    Supporter The M44 Massive

    Joined:
    Jul 8, 2014
    Messages:
    760
    Likes Received:
    366
    Trophy Points:
    76
    Location:
    Prosperous, County Kildare
    enjoy Shirley ;)
     
    • Like Like x 1
    • Thank You! Thank You! x 1
  13. Hannan Maher

    Hannan Maher Regular Member

    Joined:
    Aug 20, 2015
    Messages:
    10
    Likes Received:
    11
    Trophy Points:
    13
    This was very helpful thanks
     
    • Like Like x 1
    • Agree Agree x 1

Share This Page