Welcome to ZRoadster.org - BMW Z1 Z4 Z8 Z3 Forum and Technical Database

If you want to join in with the discussion, and see the areas which are available only to members then sign up now!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Half cover -- magnets corroding!

Discussion in 'Z3 Roadster & Coupé' started by buze, Aug 13, 2019.

  1. buze

    buze Zorg Legend
    Supporter British Zeds

    Joined:
    Jun 5, 2017
    Messages:
    419
    Likes Received:
    362
    Trophy Points:
    80
    Location:
    Berks/Powys
    Model of Z:
    2.8 Facelift
    I know many of us use these neat 'half cover' for the Z3, available on amazon etc -- I've been happy with mine for the last 2 years HOWEVER I've just discovered that some of the magnets have rusted, and are now severely marking the paint!
    Took me quite a bit of polish to remove the marks. I'm now using a small fabric pad underneath the magnets that are affected, but clearly it's not ideal...

    [​IMG]
    [​IMG]
     
  2. Geophys

    Geophys Zorg Addict
    British Zeds

    Joined:
    Dec 16, 2016
    Messages:
    149
    Likes Received:
    196
    Trophy Points:
    57
    Location:
    Bearsted, Kent
    Model of Z:
    Z3 2.2i Sport
    Yes I use one of those, I just put electrician's tape over the magnets.
     
    • Like Like x 1
  3. Bonzeau

    Bonzeau Zorg Addict
    British Zeds

    Joined:
    May 1, 2017
    Messages:
    584
    Likes Received:
    225
    Trophy Points:
    57
    Location:
    Aylsham, Norfolk
    Model of Z:
    Z3 2.8 litre Roadster
    Wasn't there a bit of a hoo haa about this on here some time ago about the magnetic strip affecting the paint, but nothing to do with rust? I think some people actually got their money back from the supplier because of the problem.
    Bonzo.
     
  4. DrWong

    DrWong Zorg Addict

    Joined:
    May 8, 2017
    Messages:
    347
    Likes Received:
    163
    Trophy Points:
    57
    Model of Z:
    3.0i
    I have a half cover and noticed the tight fit at the edges sometimes left a weird water mark on the paint after heavy rain. So I took the magnets out. When I did, they were individually sealed in plastic, presumably to prevent Buze’s situation. It might be a different cover though

    I don’t use the cover anymore because I built a carport instead