Welcome to ZRoadster.org - BMW Z1 Z4 Z8 Z3 Forum and Technical Database

If you want to join in with the discussion, and see the areas which are available only to members then sign up now!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fault codes

Discussion in 'Z3 Roadster & Coupé' started by stevie_a, Jan 9, 2012.

  1. stevie_a

    stevie_a Zorg Guru (IV)
    Scottish Zeds

    Joined:
    Jan 8, 2012
    Messages:
    1,655
    Likes Received:
    1,117
    Trophy Points:
    171
    Location:
    Glasgow'ish
    Model of Z:
    Z3
    The airbag light came on in the car again today, i have put the fault reader on to it

    it came up table 38 fault code 2 = Warn lamp

    This happened last week also but when i put the reader on and cleared it.

    but this time it is not clearing it ... ~x(

    any help appreciated.... ^:)^
     
  2. HornelZ3M

    HornelZ3M Zorg Addict
    Supporter East Anglian Crew

    Joined:
    Dec 4, 2011
    Messages:
    939
    Likes Received:
    164
    Trophy Points:
    63
    Location:
    Raglan. South Wales
    Model of Z:
    Z3M Roadster
    Firdtly i would check the connections under the seats as they operate when you put pressure on them and sometimes come loose when moving the seat.
     
  3. stevie_a

    stevie_a Zorg Guru (IV)
    Scottish Zeds

    Joined:
    Jan 8, 2012
    Messages:
    1,655
    Likes Received:
    1,117
    Trophy Points:
    171
    Location:
    Glasgow'ish
    Model of Z:
    Z3
    As said code says Warn lamp, so i suspect passenger occupancy sensor is OK also the pretensioners

    I have had these faults on my e46 before

    just never had a warn lamp before, so i don't know what to do.
     
  4. GazHyde

    GazHyde The Gaz Monkey
    Staff Member Administrator Global Moderator British Zeds

    Joined:
    Dec 2, 2011
    Messages:
    15,162
    Likes Received:
    9,255
    Trophy Points:
    226
    Location:
    Newbury, Berkshire
    Model of Z:
    BMW Z4 3.0Si Sport
  5. stevie_a

    stevie_a Zorg Guru (IV)
    Scottish Zeds

    Joined:
    Jan 8, 2012
    Messages:
    1,655
    Likes Received:
    1,117
    Trophy Points:
    171
    Location:
    Glasgow'ish
    Model of Z:
    Z3

    I have the same as you the MemoScanner B800

    my code came up 38 as code table then i pressed again and it came up 2 which reads Warn Lamp
     
  6. stevie_a

    stevie_a Zorg Guru (IV)
    Scottish Zeds

    Joined:
    Jan 8, 2012
    Messages:
    1,655
    Likes Received:
    1,117
    Trophy Points:
    171
    Location:
    Glasgow'ish
    Model of Z:
    Z3
    I have just been back out to try it again

    38 then 2 go to cancel error light goes out then back on
     
  7. stevie_a

    stevie_a Zorg Guru (IV)
    Scottish Zeds

    Joined:
    Jan 8, 2012
    Messages:
    1,655
    Likes Received:
    1,117
    Trophy Points:
    171
    Location:
    Glasgow'ish
    Model of Z:
    Z3
    Thought I would give you an update

    Well a friend came to me today with his code reader to see if he could put out the air bag light

    when he took it out the bag i noticed it was not the big round plug, so i got mine to put on to his reader

    just then he said to me "put your machine on and try it again to i see the fault"

    so i did and the error code came back up so i put it to clear codes, and to my surprise the light went out and staid out ... :D

    don't know why it would not go out before... x_x
     
  8. GazHyde

    GazHyde The Gaz Monkey
    Staff Member Administrator Global Moderator British Zeds

    Joined:
    Dec 2, 2011
    Messages:
    15,162
    Likes Received:
    9,255
    Trophy Points:
    226
    Location:
    Newbury, Berkshire
    Model of Z:
    BMW Z4 3.0Si Sport
    Hmmmm. Have the same code now showing on mine with the same code reader.

    Tried several times now to reset the light, but it doesn't! Will only work on the round connector under the bonnet, and gives a connection error on the ODB port under the steering column. Can't remember which I used it on the first time...
     
  9. r37

    r37 Dedicated Member

    Joined:
    Dec 7, 2011
    Messages:
    293
    Likes Received:
    0
    Trophy Points:
    29
    on a similar note, after removing my seats to clean them i now get the light aswell. I think its because i turned the ignition on to put the roof up/down so i could clean behind it and the light doesnt re-set. So if anyone in the midlands has a code reader i can borrow....
     
  10. gookah

    gookah Zorg Guru (IV)
    British Zeds

    Joined:
    Dec 7, 2011
    Messages:
    2,282
    Likes Received:
    1,119
    Trophy Points:
    150
    Location:
    Shropshire
    Model of Z:
    2.8 Z3

    I could only ever reset with the round connector under the bonnet, but they stayed off afterwards.
    Came on because I turned ignition on, with seat removed....Doh
     
  11. gookah

    gookah Zorg Guru (IV)
    British Zeds

    Joined:
    Dec 7, 2011
    Messages:
    2,282
    Likes Received:
    1,119
    Trophy Points:
    150
    Location:
    Shropshire
    Model of Z:
    2.8 Z3

    I will take my code readers to SantaPod if anyone wants to try a reset..
     
  12. stevie_a

    stevie_a Zorg Guru (IV)
    Scottish Zeds

    Joined:
    Jan 8, 2012
    Messages:
    1,655
    Likes Received:
    1,117
    Trophy Points:
    171
    Location:
    Glasgow'ish
    Model of Z:
    Z3
    just an update to this my light has came on several times now, also know why

    as every time my wife got in the first thing she done was put the seat right up.... :-o

    it all fell into place, now when it goes on ( not very often now she received a telling off from me)

    i firstly with the ignition off put my hand under the seat and make sure the wires are all ok

    then put the code reader on, if it does not go out ignition back off move the wires under the seat and try again with the code reader until all lights go out.
     

Share This Page