Welcome to ZRoadster.org - BMW Z1 Z4 Z8 Z3 Forum and Technical Database

If you want to join in with the discussion, and see the areas which are available only to members then sign up now!

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Door solenoid

Discussion in 'Z3 M Roadster & Coupé' started by badman gee, Sep 13, 2013.

  1. badman gee

    badman gee Guest

    Hello all

    My drivers door won't open via the remote (passenger door ok)

    It could be a solenoid failure?

    It was intermittent for a while but now packed up.

    Is it easy to get too?

    Many thanks
     
  2. GazHyde

    GazHyde The Gaz Monkey
    Staff Member Administrator Global Moderator British Zeds

    Joined:
    Dec 2, 2011
    Messages:
    15,210
    Likes Received:
    9,349
    Trophy Points:
    226
    Location:
    Newbury, Berkshire
    Model of Z:
    BMW Z4 3.0Si Sport
    Have you checked the wiring in the boot lid, which tends to be a common cause?
     
  3. badman gee

    badman gee Guest

    No mate. Under the carpet is it?
     
  4. badman gee

    badman gee Guest

    Can have a look Sunday if you like?
     
  5. GazHyde

    GazHyde The Gaz Monkey
    Staff Member Administrator Global Moderator British Zeds

    Joined:
    Dec 2, 2011
    Messages:
    15,210
    Likes Received:
    9,349
    Trophy Points:
    226
    Location:
    Newbury, Berkshire
    Model of Z:
    BMW Z4 3.0Si Sport
    It's where the wiring loom goes through to the boot lid (by the hinges).
    Yeah, we can have a look. It's pretty obvious if it's the loom or not.
     
  6. hard top

    hard top Zorg Expert (I)
    Dutch Zeds The M44 Massive

    Joined:
    Dec 5, 2011
    Messages:
    20,779
    Likes Received:
    6,064
    Trophy Points:
    213
    Location:
    Netherlands
    Can you open it with key Mark.....?.....
     
  7. badman gee

    badman gee Guest

    Don't know. Lock covered by chrome cover (no key hole!)
     
  8. badman gee

    badman gee Guest

    Yes I suppose it is.

    It's only just stopped working. Ok yesterday.
     
  9. TitanTim

    TitanTim Dedicated Member

    Joined:
    Dec 7, 2011
    Messages:
    238
    Likes Received:
    7
    Trophy Points:
    43
    Sounds like the solenoid, if it was the boot loom the central locking will just die and if shorts will blow the fuse. Its worth checking the loom anyways as it will fail sooner or later so you will lose central locking, boot brake light etc.

    Tim.
     
  10. jonco

    jonco Zorg Guru (III)
    Supporter British Zeds The M44 Massive

    Joined:
    Dec 6, 2011
    Messages:
    1,350
    Likes Received:
    673
    Trophy Points:
    149
    Location:
    Chester
    Model of Z:
    '98 1.9 Auto
    So that rules out it being gummed up with polish then! :D
    Check the boot loom thoroughly it is not always obvious.
     
  11. z3cade

    z3cade Zorg Guru (III)
    East Anglian Crew

    Joined:
    Dec 4, 2011
    Messages:
    1,980
    Likes Received:
    315
    Trophy Points:
    137
    Location:
    Peterborough
    Lack of use is the problem :p
     
  12. badman gee

    badman gee Guest

    Yours will fail soon then