Code reader not saying any faults but have asc and abs light

Daz3

Zorg Legend
Joined
Dec 8, 2011
Messages
618
Location
Spilsby, Lincolnshire
Model of Z
2.8 Roadster
I've bought a peake code reader and just tried it on the zed to clear some lights. However it says there's no faults but I have an abs light and the light in between the speedo and tachometer which comes on when the asc buttons pressed. Any ideas? Does the peake tool not clear abs lights I thought it would?
 

GazHyde

Administrator
Administrator
Global Moderator
M Power
Joined
Dec 2, 2011
Messages
15,875
Location
Newbury, Berkshire
Model of Z
Z4 M Roadster
Re: Code reader not saying any faults but have asc and abs l

Daz3 said:
I've bought a peake code reader
Which one is it Daz, if I remember correctly they make a few different ones :-\
 

stevie_a

Zorg Guru (IV)
Scottish Zeds
Joined
Jan 8, 2012
Messages
1,708
Location
Glasgow'ish
Model of Z
Z3
Re: Code reader not saying any faults but have asc and abs l

Daz3 said:
no faults but I have an abs light and the light in between the speedo and tachometer which comes on when the asc buttons pressed. Any ideas?
that is correct, if you press the button and the light comes on and press again and it goes off it is working correct.

when the light is on the abs has been switched off { lots of sideways action}

when light is out abs is switched on { no sideways action}

;) ;) ;) ;) ;) ;) ;) ;) ;) ;) ;) ;) ;) ;) ;) ;)
 

Daz3

Zorg Legend
Joined
Dec 8, 2011
Messages
618
Location
Spilsby, Lincolnshire
Model of Z
2.8 Roadster
Re: Code reader not saying any faults but have asc and abs l

What I meant to say was the lights are on all the time pressing the button makes no difference.
 

r37

Dedicated Member
Joined
Dec 7, 2011
Messages
293
Re: Code reader not saying any faults but have asc and abs l

sounds stupid but could the bulb be broken, any wires stripped behind the clusters that are shorting on something? Failing that try a burnout on the drive. will soon tell you if the traction controll is working.
 

Daz3

Zorg Legend
Joined
Dec 8, 2011
Messages
618
Location
Spilsby, Lincolnshire
Model of Z
2.8 Roadster
Re: Code reader not saying any faults but have asc and abs l

Bulbs working as its on. Wires behind the clusters are fine. I may try the burnout method though =))
 

Brian H

Zorg Expert (I)
Supporter
British Zeds
Scottish Zeds
Joined
Dec 5, 2011
Messages
3,693
Location
Killin
Model of Z
E36/7 3.0i - E85 Z4///M
Re: Code reader not saying any faults but have asc and abs l

Daz,

Does the code reader plug in under the dash (OBDII) or bonnet (OBD)? Many modules are not available using the OBDII port.

Brian

Edit: Just had a very quick scan through the R5 FCX 3 Manual and I cannot see any reference to ABS fault codes in the tables.
 

z3cade

Zorg Guru (III)
East Anglian Crew
Joined
Dec 4, 2011
Messages
1,980
Location
Peterborough
Re: Code reader not saying any faults but have asc and abs l

Just stick some black tape over the lights. :-bd

You can still borrow my airbag reset tool if u want,
 

heath

Regular Member
Joined
Dec 22, 2011
Messages
88
Location
Burton on Trent
Model of Z
Z3 2.0 individual
Re: Code reader not saying any faults but have asc and abs l

Some code readers which will read engine codes, abs & airbag will ask you which system you want to read when it has been connected to the car. If it doesn't ask & just scans for codes it is most likely just searching for engine codes. Also as Brian says you need to use the big round plug under the bonnet for reading ABS (this is for cars 2000 or before, dont know if its the same for later cars)


Heath on Tapatalk
 

g8jka

Zorg Guru (V)
Supporter
British Zeds
Joined
Dec 5, 2011
Messages
2,661
Location
Telford, Shropshire
Model of Z
Z3 - 2000 2.8 Roadster
Re: Code reader not saying any faults but have asc and abs l

Do you mean you have both the ABS light and ACS light on at the same time? Isn't that something to do with a faulty ABS sensor that may need cleaning?

My ABS and ACS lights come on every so often but when you hit 15MPH they go out, this is caused by a faulty ABS sensor which I really needs a good clean. With the lights both illuminated at the same time neither the ABS or ACS will work on the car.
 

Daz3

Zorg Legend
Joined
Dec 8, 2011
Messages
618
Location
Spilsby, Lincolnshire
Model of Z
2.8 Roadster
Re: Code reader not saying any faults but have asc and abs l

I don't think the black tape method will impress the mot man ^#(^
It plugs under the bonnet in the big round plug. I've just thought I think I left one of the abs cables unplugged and turned the ignition on which is when the codes come up so may just need running up the road to reset? Failing that I'll give the sensors a clean. Thanks everyone!
 

Brian H

Zorg Expert (I)
Supporter
British Zeds
Scottish Zeds
Joined
Dec 5, 2011
Messages
3,693
Location
Killin
Model of Z
E36/7 3.0i - E85 Z4///M
Re: Code reader not saying any faults but have asc and abs l

Daz3 said:
I've just thought I think I left one of the abs cables unplugged and turned the ignition on which is when the codes come up so may just need running up the road to reset? Failing that I'll give the sensors a clean. Thanks everyone!
Having the sensor unplugged will cause an error, running on the road should clear the lights but the memory will still show the error/s should you ever read them.
 

Daz3

Zorg Legend
Joined
Dec 8, 2011
Messages
618
Location
Spilsby, Lincolnshire
Model of Z
2.8 Roadster
Re: Code reader not saying any faults but have asc and abs l

Ok thanks for your help everyone I'll see if it sorts itself out when I get my seats back in ;)
 
Z

zedonist

Guest
Re: Code reader not saying any faults but have asc and abs l

You dont have over spray on the sensors do you?
 

Daz3

Zorg Legend
Joined
Dec 8, 2011
Messages
618
Location
Spilsby, Lincolnshire
Model of Z
2.8 Roadster
Re: Code reader not saying any faults but have asc and abs l

zedonist said:
You dont have over spray on the sensors do you?
Shouldnt have they were all bagged off for spraying
 
Z

zedonist

Guest
Re: Code reader not saying any faults but have asc and abs l

Just a thought, mine come on periodically, code reader identifies nothing, a quick swill off of the brake dust and all back working again, just thought you may have hazed them with some over spray
 

Daz3

Zorg Legend
Joined
Dec 8, 2011
Messages
618
Location
Spilsby, Lincolnshire
Model of Z
2.8 Roadster
Re: Code reader not saying any faults but have asc and abs l

zedonist said:
Just a thought, mine come on periodically, code reader identifies nothing, a quick swill off of the brake dust and all back working again, just thought you may have hazed them with some over spray
Yeah maybe it being stood for a year wont help I'll see what happens when I take it for a spin. Thanks again I'll post up the results when she's ready to meet the tarmac :coolsteer)
 

simonlincs

Zorg Addict
Supporter
Joined
May 5, 2015
Messages
142
Location
Sleaford
Model of Z
2.8
Daz, did you get to the bottom of this as I have the same issue?, cheers Simon
 

Daz3

Zorg Legend
Joined
Dec 8, 2011
Messages
618
Location
Spilsby, Lincolnshire
Model of Z
2.8 Roadster
Hi yeah the code reader I had didn't seem to read the abs system so I took it to a garage and there computer came up with the abs pump at fault. I've replaced the unit and put new front sensors on for good measure, but I can't say if it works as haven't been able to take it up the road.
 
Top