Battery problem??

Mr Silver

Regular Member
Joined
Dec 7, 2011
Messages
6
After lay up over winter brand new Varta battery keeps going flat. Returned three times to the seller (a good friend of mine) and he believes that a fault on the car (Z3 3.0) is the reason. BMW tell me that the ECU goes into sleep mode after 16 minutes but does anyone here know the static current drain on the battery in sleep mode. I am reading 70 ma which seems a bit high. Hopefully will be reading codes today but I suspect that they may not provide the answer. Otherwise car runs fine. Appreciate any information.
 

mwpe

Zorg Guru (IV)
Supporter
Joined
Dec 8, 2011
Messages
3,607
Location
Camberley
Model of Z
3.0
A favorite cause of battery drain is the boot light staying on. Set your phone to video, put it in the boot and close, then check the video to see if it goes out.
 

g8jka

Zorg Guru (V)
Supporter
British Zeds
Joined
Dec 5, 2011
Messages
2,599
Location
Telford, Shropshire
Model of Z
Z3 - 2000 2.8 Roadster
I've found if a battery goes flat through lack of use on any zed then that's the end of it. If your putting a new battery on a leaving it laid up for months it won't do the battery any good. You need to leave it on trickle charge, disconnect it or better still take it out for a good run every so often. That's all if it's going flat through lack of use of the winter. You may have other problems causing them to drain as suggested above like the boot light which is a common problem.

When it's in constant use, do you have any problems with the battery?
 
Top