Poor Ariel Signal

Keavo69

Dedicated Member
British Zeds
Joined
Mar 19, 2016
Messages
80
Location
Newton abbot
Model of Z
Z3 2.8 roadster
Hi all I’ve recently changed the z3’s head unit to a more modern Sony
Mex -N4200bt unit and the radio signal is awful I tuned all the stations while sat in the garage and all was well
But out on the road not getting much of a reception has anyone got any ideas of the cause or how I can boost the signal
Cheers marv
 

Keavo69

Dedicated Member
British Zeds
Joined
Mar 19, 2016
Messages
80
Location
Newton abbot
Model of Z
Z3 2.8 roadster
Looks like I’ll Just Have to keep to blue tooth then
 

Oddly Godly

Zorg Guru (I)
Supporter
British Zeds
Joined
May 17, 2019
Messages
453
Location
dunstable
Model of Z
z3 2.8
I have just updated to a head unit with dab, I have a windscreen mounted aerial for the dab. My original antenna is rubbish and became worse after someone broke it off. I glued it back together but it not good. I am hopeing to find some sort of replacement and remove the original which has a built in amplifier. Its a bit of a pain as I will have to find some way of getting the antenna cable from the boot to the head unit. As you don't have dab you could try a windscreen mounted aerial. My dab one was pretty easy to fit and hide the cable up the side of the windscreen behind the plastic
 

Eddie Zedder

Zorg Guru (III)
Supporter
British Zeds
Joined
Jun 10, 2015
Messages
2,006
Location
Megawatt Valley, Notts.
Model of Z
Z3 2.0
Quite a common occurrence for a Z3 aerial. Most likely it has been broken off where the ball end fits into the grommet and then glued back together. Most people don't realise that there is a wire connected to the threaded socket and that breaks as well, hence the poor reception.
 
Top